Cómo comparar dos columnas en excel o hallar la intersección de dos conjuntos.

August 25, 2011 | Autor: | Publicado en Internet

Algunas veces tenemos que comparar dos columnas con información parecida en excel. Deseamos saber que elementos de una columna están presentes en otra y cuáles no. Esta fórmula te ayuda a encontrar la intersección de dos conjuntos.

Aquí te mostramos dos métodos para hacerlo. Como ejemplo nos proponemos solucionar este problema.
Queremos saber qué países del listado de Países de América están en el listado países de América del Sur.

Países de América Países de América del sur
Argentina
Bolivia
Brasil
Canadá
Chile
Colombia
Costa Rica
Cuba
República Dominicana
Ecuador
El Salvador
Guatemala
Haití
Honduras
Jamaica
México
Nicaragua
Panamá
Paraguay
Perú
Trinidad y Tobago
Estados Unidos
Uruguay
Venezuela
Argentina
Bolivia
Brasil
Chile
Colombia
Ecuador
Paraguay
Perú
Uruguay
Venezuela

Primer método: En tu hoja de excel.

  1. Hay que tener las dos columnas A (Países de América) y C (Países de América del Sur) con los datos ordenados alfabéticamente.
  2. En la columna B que está vacía copia la siguiente fórmula en la primera celda.
    • En español:  =SI(ESERROR(COINCIDIR(A1,$C$1:$C$10,0)),”",A1)
    • En inglés: =IF(ISERROR(MATCH(A1,$C$1:$C$10,0)),”",A1)
    • En alemán: =WENN(ISTFEHLER(VERGLEICH(A4;$C$1:$C$20;0));”";A4)

    Esta fórmula busca si el elemento de la columna A está en el grupo de la columna C con la función COINCIDIR.
    La función ESERR verifica si la anterior función devolvió error o no
    y si no devolvió error, es decir, el elemento está presente, lo imprime.

  3. Aplica la fórmula a las otras casillas en la columna B y listo.

Segundo método: Házlo online.

  1. Entra al sitio:

    http://xlcomparator.net

  2. Sube tus dos archivos con tus dos columnas y compáralos.

Puedes utilizar estos sencillos métodos para extraer por ejemplo de una lista de precios un determinado pedido y muchas otras cosas.

Autor:

Este autor ha publicado 3 Cómos. Próximamente más información acerca de este autor.

Comentarios (6)

  1. Javier

    Como puedo saber si el valor en una columna esta contenido en otra, no logro desarrollar bien la formula,
    Last 7 Extrac Result
    2076787 5084041 =BUSCARV($F$2;D2:D147;”";FALSO)
    2076663 5067581
    2076500 2080245
    2073496 5083021
    2076617 2081273
    5067647 5073431
    5069010 5073283
    5067918 5067632
    5067581 5069951
    5067639 2087557
    5067632 5081246
    5069130 5083938
    5069242 5068203
    5068047 5067639
    5067859 5080783
    5068203 5080105
    5069842 5084207
    5068247 2082156
    5070043 5092869
    5068873 5092478

    • Carlos Perea

      Prueba otra vez con la fórmula de excel que arriba recomiendo. Pues a mi me sale el resultado esperado.
      Bueno si eso es lo que buscas.

      2076787 5084041
      2076663 5067581
      2076500 2080245
      2073496 5083021
      2076617 2081273
      5067647 5073431
      5069010 5067581 5073283
      5067918 5067639 5067632
      5067581 5067632 5069951
      5067639 2087557
      5067632 5081246
      5069130 5083938
      5069242 5068203
      5068047 5068203 5067639
      5067859 5080783
      5068203 5080105
      5069842 5084207
      5068247 2082156
      5070043 5092869
      5068873 5092478

  2. SANTIAGO CRUZ MOLINA

    gracias, hasta que di con la repuesta correcta, despues de estar buscando por dos dias, tu respuesta fue la que verdaderamente me ayudo. MUCHICIMAS GRACIAS, ME HAS SALVADO

  3. jose

    El problema que tenías en la fórmula del Buscarv está en el parametro de matriz donde buscar D2:D147. El tema es que si lo pones así al copiar la fórmula en la celda siguiente se transforma en D3:D148 por lo que no buscas en todo el rango de celdas y el problema es el tercer parámetro que utilzias Indicador de columnas.

    Tu fórmula es correcta pero falta hacer que la matriz sea absoluta y no relativa. Para hacerla absoluta (FIJA) marcamos el carácter del dólar delante de la letra y delante del número de la celda $D$2:$D$147.
    El indicador de columnas es cuantos lugares tiene que moverse para darte el resultado. Si la búsqueda la haces de la columna D a la columna D sólo puede moverse una columna que es donde está tu resultado

    Tu función quedaría
    ColumnaD ColumnaF
    2076787 5084041 =BUSCARV($F$2;$D$2:$D$147;1;FALSO)
    2076663 5067581
    2076500 2080245
    2073496 5083021
    2076617 2081273
    5067647 5073431
    5069010 5073283
    5067918 5067632

  4. HGC

    Perfecto, muchas gracias

Deja un mensaje