Archivo de la etiqueta: excel

Cómo comparar dos columnas en excel o hallar la intersección de dos conjuntos.

Algunas veces tenemos que comparar dos columnas con información parecida en excel. Deseamos saber que elementos de una columna están presentes en otra y cuáles no. Esta fórmula te ayuda a encontrar la intersección de dos conjuntos.

Aquí te mostramos dos métodos para hacerlo. Como ejemplo nos proponemos solucionar este problema.
Queremos saber qué países del listado de Países de América están en el listado países de América del Sur.

Países de América Países de América del sur
Argentina
Bolivia
Brasil
Canadá
Chile
Colombia
Costa Rica
Cuba
República Dominicana
Ecuador
El Salvador
Guatemala
Haití
Honduras
Jamaica
México
Nicaragua
Panamá
Paraguay
Perú
Trinidad y Tobago
Estados Unidos
Uruguay
Venezuela
Argentina
Bolivia
Brasil
Chile
Colombia
Ecuador
Paraguay
Perú
Uruguay
Venezuela

Primer método: En tu hoja de excel.

  1. Hay que tener las dos columnas A (Países de América) y C (Países de América del Sur) con los datos ordenados alfabéticamente.
  2. En la columna B que está vacía copia la siguiente fórmula en la primera celda.
    • En español:  =SI(ESERROR(COINCIDIR(A1,$C$1:$C$10,0)),””,A1)
    • En inglés: =IF(ISERROR(MATCH(A1,$C$1:$C$10,0)),””,A1)
    • En alemán: =WENN(ISTFEHLER(VERGLEICH(A4;$C$1:$C$20;0));””;A4)

    Esta fórmula busca si el elemento de la columna A está en el grupo de la columna C con la función COINCIDIR.
    La función ESERR verifica si la anterior función devolvió error o no
    y si no devolvió error, es decir, el elemento está presente, lo imprime.

  3. Aplica la fórmula a las otras casillas en la columna B y listo.

Segundo método: Házlo online.

  1. Entra al sitio:
    http://xlcomparator.net
  2. Sube tus dos archivos con tus dos columnas y compáralos.

Puedes utilizar estos sencillos métodos para extraer por ejemplo de una lista de precios un determinado pedido y muchas otras cosas.

Cómo llevar un control de gastos con Excel

No es necesario que se complique la vida con programas intrincados o costosos si tiene la necesidad de llevar un control de gastos simple o un presupuesto familiar.
Con la popular hoja de cálculo Excel, es posible hacerlo del siguiente modo:

Instrucciones:

  1. Abra un documento nuevo en Excel.
  2. En las cuatro primeras celdas de la fila inicial escriba los encabezados de sus columnas: fecha, detalle o concepto, entrada (ingreso) y salida (egreso).
  3. Si se trata de gastos previstos o de un presupuesto familiar, escriba los nombres de cada rubro bajo la columna designada como “detalle” o “concepto”. Si más adelante necesita introducir algún otro ítem en medio de filas que ya tienen información, sólo es  necesario que haga clic derecho sobre el número de la fila que corresponda y elija la opción “insertar”.
  4. Vaya a la fila siguiente donde terminan los rubros enumerados y seleccione un poco más abajo una celda vacía que corresponda a la columna “entrada”. Haga clic en la pestaña inicio, junto al ícono de grabar archivo, y ubique, cerca de la esquina superior derecha, el botón de sumatoria (distinguido con el signo S). Presiónelo, y de inmediato verá que en la celda escogida con anterioridad aparecerá el texto =SUMA(). En la misma columna, haga clic sostenido y arrastre el puntero, desde la celda de la segunda fila hasta la celda que se encuentra encima de la que usó para el inicio de esta operación. Repita el procedimiento en la columna de egresos. De esta forma, habrá introducido una fórmula sencilla que se dará como primer resultado cero, debido a que no hay todavía cifras para sumar. En la medida en que usted introduzca los valores que corresponden a cada gasto o ingreso, la hoja de cálculo hará automáticamente la suma de lo registrado.
  5. Para establecer la diferencia entre ingresos y egresos, seleccione una celda al lado derecho de la que muestra el total de los gastos. Haga nuevamente clic en el símbolo de sumatoria (S) y automáticamente aparecerá una línea punteada que abarca los totales de ingresos y egresos. También será visible un texto que empieza por =SUMA(). Introduzca un signo menos entre el signo igual y la S, de modo que se vea =-SUMA(). Pulse enter y al instante la hoja de cálculo le informará sobre la diferencia entre las entradas y las salidas de dinero.
  6. Si en el caso de un presupuesto familiar usted quiere llevar un control de gastos mes a mes, haga clic derecho en la pestaña inferior usualmente identificada como Hoja1. De inmediato verá un pequeño menú en el que escogerá “mover o copiar”. Cree las copias que necesite y al final, oprimiendo de nuevo el botón derecho de su mouse, busque la opción renombrar para asignarle a cada pestaña el nombre del mes que registrará.