Archivo de la etiqueta: intersección conjuntos

Cómo comparar dos columnas en excel o hallar la intersección de dos conjuntos.

Algunas veces tenemos que comparar dos columnas con información parecida en excel. Deseamos saber que elementos de una columna están presentes en otra y cuáles no. Esta fórmula te ayuda a encontrar la intersección de dos conjuntos.

Aquí te mostramos dos métodos para hacerlo. Como ejemplo nos proponemos solucionar este problema.
Queremos saber qué países del listado de Países de América están en el listado países de América del Sur.

Países de América Países de América del sur
Argentina
Bolivia
Brasil
Canadá
Chile
Colombia
Costa Rica
Cuba
República Dominicana
Ecuador
El Salvador
Guatemala
Haití
Honduras
Jamaica
México
Nicaragua
Panamá
Paraguay
Perú
Trinidad y Tobago
Estados Unidos
Uruguay
Venezuela
Argentina
Bolivia
Brasil
Chile
Colombia
Ecuador
Paraguay
Perú
Uruguay
Venezuela

Primer método: En tu hoja de excel.

  1. Hay que tener las dos columnas A (Países de América) y C (Países de América del Sur) con los datos ordenados alfabéticamente.
  2. En la columna B que está vacía copia la siguiente fórmula en la primera celda.
    • En español:  =SI(ESERROR(COINCIDIR(A1,$C$1:$C$10,0)),””,A1)
    • En inglés: =IF(ISERROR(MATCH(A1,$C$1:$C$10,0)),””,A1)
    • En alemán: =WENN(ISTFEHLER(VERGLEICH(A4;$C$1:$C$20;0));””;A4)

    Esta fórmula busca si el elemento de la columna A está en el grupo de la columna C con la función COINCIDIR.
    La función ESERR verifica si la anterior función devolvió error o no
    y si no devolvió error, es decir, el elemento está presente, lo imprime.

  3. Aplica la fórmula a las otras casillas en la columna B y listo.

Segundo método: Házlo online.

  1. Entra al sitio:
    http://xlcomparator.net
  2. Sube tus dos archivos con tus dos columnas y compáralos.

Puedes utilizar estos sencillos métodos para extraer por ejemplo de una lista de precios un determinado pedido y muchas otras cosas.